Actuacting, Sensing and Control Mechatronic Systems ; RsM

Lab: Getting started with Quartus Prime Software Ketodes Roboty s Hecharonk

Quartus Prime — Create a new project

1. The first step in creating a new project in Quartus Prime is to create a new directory where all project files
will be stored. The directory path must not contain spaces or Polish diacritical characters (e.g., 3, €, §, etc.).

2. You should copy the specified file with the gsf extension into the project directory. This file links the
symbolic names of the input/output pins used in the project with the physical pins of the FPGA
device.

3. Launch the Quartus Prime program and open the New Project Wizard from the welcome window
by selecting Create a New Project (New Project Wizard) or navigating to File -> New Project
Wizard... The New Project Wizard window will appear (Fig. 1). Click the Next button.

QA New Project Wizard s

Introduction

The New Project Wizard helps you create a new project and preliminary project settings, including the

following:

* Project name and directory

* Name of the top-level design entity
* Project files and libraries

* Target device family and device

* EDA tool settings

You can change the settings for an existing project and specify additional project-wide settings with the
Settings command (Assignments menu). You can use the various pages of the Settings dialog box to add
functionality to the project.

1 Don't show me this introduction again

< Back Finish Cancel Help

Fig. 1: New Project Wizard — Window 1
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4. In the next window (Fig. 2), specify the previously created directory as the project location and
enter the project name. The name must not contain spaces and cannot start with a digit. Click the

Next button.

(O New Project Wizard X
Directory, Name, Top-Level Entity
What is the working directory for this project?
|E/FPGA/Dydakiyka/Prolab] |-
What is the name of this project?
‘ProLahO_Fundamemals ‘
What is the name of the top-level design entity for this project? This name is case sensitive and must exactly
match the entity name in the design file.
‘ProLabO_Fundamentals
Use Existing Project Settings...
< Back Finish Cancel Help
Fig. 2: New Project Wizard — Window 2
5. Inthe next window (Fig. 3), you should select the "Empty Project" option.
X

G New Project Wizard

Project Type
Select the type of project to create.

® Empy project
Create new project by specifying project files and libraries, target device family and device, and EDA tool
settings.

O Project template

Create a project from an existing design template. You can choose from design templates installed with
the Quartus Prime software, or download design templates from the Design Store.

< Back Finish Cancel Help

Fig. 3: New Project Wizard — Window 3
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6. In the next window (Fig. 4), you can add external (previously created) files to the project. In this

case, it is recommended that they be copied to the project directory beforehand. If you are not
adding any new files, click the Next button.

O New Project Wizard
Add Files

Select the design files you want to include in the project. Click Add All to add all design files in the project
directory to the project.

Note: you can always add design files to the project later.

File name: | Add
. %] add Al
File Name Type Library Design Entry/Synthesis Tool HDL Version Remove
Up
Down
Properties

Specify the path names of any non-default libraries. \User Libraries...

< Back Finish Cancel Help

Fig. 4: New Project Wizard — Window 4

7. Next, you need to select the FPGA family and the device that is on the DE10-Lite board. The family

and device information can be found on the FPGA itself, the packaging, or the documentation
provided by the manufacturer of the DE10-Lite board.

G New Project Wizard

Family, Device & Board Settings

Device Board

Select the family and device you want to target for compilation.
You can install additional device support with the Install Devices command on the Tools menu.
To determine the version of the Quartus Prime software in which your target device is supported, refer to the Device Support List webpage.

Device family Show in 'Available devices' list

Family: | MAX 10 (DA/DF/DC/SA/SC) -

Package: .Any =

Device: All = Pin count Any -

Target device Core spged grade: Any ¥
Auto device selected by the Fitter Name filter:

® Specific device selected in ‘Available devices' list Show advanced devices
Other: nfa

Ayailable devices:

Na’;ne Core Voltage LEs Total 1/0s GPIOs y Bits ier 9-bitel
T0M50DAF484C8G 1.2V 49760 360 1677312
__—
10M50DAF484C6GES 1.2V 49760 360 1677312
10M50DAF25617G 1.2V 49760 178 178 1677312 288 b
< 3

< Back FEinish Cancel Help

Fig. 5: New Project Wizard — Window 5
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8. The next window allows you to configure the integrated helper tools for analysis, synthesis, and
simulation. We will leave everything unchanged and click the Next button.

(G New Project Wizard X

EDA Tool Settings

Specify the other EDA tools used with the Quartus Prime software to develop your project.

EDA tools:
Tool Type Tool Name Format(s) Run Tool Automatically
’Design Entry/s. <None> ¥ | <None> Run this tool automatically to synthesize the current design
Simulation <None> ¥ | <None> Run gate-level simulation automatically after compilation
Board-Level Timing <None> v

Symbol <None> A

Signal Integrity <None> -

Boundary Scan <None>

< Back Finish Cancel Help

Fig. 6: New Project Wizard — Window 6

9. The last window of the wizard is a summary. If all parameters are correct, click the Finish button.

(G New Project Wizard X

Summary

‘When you click Finish, the project will be created with the following settings:

Project directory: E:fFPGA/Dydaktyka/ProLab0
Project name: ProLab0_Fundamentals
Top-level design entity: ProLabO_Fundamentals
Number of files added: 0

Number of user libraries added: 0

Device assignments:

Design template: nfa
Family name: MAX 10 (DA/DF/DC/SA/SC)
Device: 10M50DAF484C7G
Board: nfa
EDA tools:
Design entry/synthesis: <None> (<None>)
Simulation: <None> (<None>}
Timing analysis: 0

Operating conditions:

Core voltage: 1.2V
Junction temperature range: 0-85°C
< Back Next > Cancel Help

Fig. 7: New Project Wizard — Window 7
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10. After completing the project setup wizard, a blank Quartus Prime window should appear (Fig. 8).

(b Quartus Prime Standard Edition - E/FPGA/D: roLab0/ProLab0_F - Prolab0_F

x

Search alteracom @

File Edit View Project Assignments Processing Tools Window Help

i0MmE/ #00 "D C [protabo Fundamentals ~| < $ E % Tr K ES S AV R

Project Navigator |\ Hierarchy REEEE

i MAX 10: 10M50DAF484C7G
* ProLab0_Fundamentals &

[Tasks Compilation ~=mex

. > Quartus Prime

ard Editio
Task ~

v P> Compile Design
> P Analysis & Synthesis
> P> Fitter (Place & Route)
> B Assembler (Generate programming fils
> P> Timing Analysis o
>

~

Quartus Prime Tcl Console
o

Al (@ [&] [a] [ <ritter>> | @8 cind.. | |88 Find Next|

Tvpe ID Messaae
© 253020 Default device 10MO8DAF484C8G is automatically selected for the device family MAX 10

e Ee

System (1) Processing

0%  00:00:00

Fig. 8: Quartus Prime Window

11. The next step is to add a block diagram file to the project. To do this, select File -> New, and then
choose Block Diagram/Schematic File (Fig. 9).

i@ New X

MNew Quartus Prime Project &

“ Design Files

AHDL File

Block Diagram/Schematic File

EDIF File

Qsys System File

State Machine File

SystemVerilog HDL File

Tcl Script File

Verilog HDL File

VHDL File
v Memory Files

Hexadecimal (Intel-Format) File

Memory Initialization File
v Verification/Debugging Files

In-System Sources and Probes ... o,

OK H Cancel H Help

Fig. 9: New file Window
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12. A blank block diagram will appear in the main Quartus Prime window (Fig. 10). Next, save the file by selecting
File -> Save As... and give it an appropriate name, such as Top.bdf. At this stage, the newly created and saved
file should appear in the project’s Files tab. The final step is to inform the compiler that this is the top-level

file in the project. This is done by selecting the Set as Top-Level Entity option from the menu that appears
when you right-click on the file.

(b Quartus Prime Standard Edition - E/FPGA/Dydaktyka/ProLab0/ProLab0_Fundamentals - ProLab0_Fundamentals
File Edit View Project Assignments Processing Tools Window Help

Or r ProLab0_Fundamentals ~ < & & < PEFES @AVE
Project Navigator ] Fites ~leme | T Top.bdf a
Files - r BrQA¥WADR-OITIANNNOSN N [ A S
E2 Top.bdf ~
[Tasks Compilation v =lnex
Task <
v P Compile Design
P> Analysis & Synthesis
P> Fitter (Place & Route)
D> Assembler (Generate programming fil¢
P Timing Analysis " "
< > |« >
* |Quartus Prime Tcl Console
|4
fi
2
fi
=|[tvoe 1D
© 253

020 Default device 10MOBDAF484C8G is automatically selected for the device family MAX 10

[Messages

System (1) Processing

437,1 0%  00:00:00

Fig. 10: Blank block diagram file in Quartus Prime

13. The basic elements that can be used to build the diagram are located by clicking on
the Symbol Tool button (Fig. 11).

G Quartus Prime Standard Edition - E/FPGA/Dydaktyka/ProLab0/ProLab0_Fundamentals - ProLab0_Fundamentals
File Edit View Project Assignments Processing Tools Window Help

O r Prolab0 Fundamentals ~ ~ & 4 T r F E S @ LD R

Project Navigator El Files ~ape x| % Top.bdf (]
Files = r B rhkQWATE~-O"11INNSNSOON N [HIH A €4t
& Topbdr TR AR R e enR e e h a e

- | symbol Tool

Fig. 11: Symbol Tool
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14. To build the simplest project, select one of the available logic gates (Fig. 12).

" Symbol X

Libraries:

v & cfintelfpga/18.1/quart. ™
£ megafunctions
& others
v & primitives
& buffer

v & logic
£ and12
& and2
£ and3

£ and4 v
< >

Name:

Repeat-insert mode

] Insert symbol as block

Fig. 12: Symbol Tool Window

15. The next step is to add input/output ports found under the Pin Tool button (Fig. 13).

O Quartus Prime Standard Edition - E/FPGA/Dydaktyka/Prolab0/ProLab0_Fundamentals - ProLab0_Fundamentals

File Edit View Project Assignments Processing Tools Window Help

OFH nim ProLabo_Fundamentals ~| < & E 5 T r F E S @A DR

Project Navigator E Files ~lame = T Top.bdf* (%]
Files = | alle) HixaWACESO 1IN SO ™ [HE A S L
& Top.bdf oo e s leinpnt

‘® Output
o

Fig. 13: Pin Tool
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16. At this stage, the program window should resemble that shown in Fig. 14. After assigning
appropriate symbolic names to the pins (e.g., SW[0], SW[1] as inputs and LEDR[0] as an output), the
project is ready for analysis and synthesis. To do this, click the Start Analysis & Synthesis button
located on the toolbar, or select Processing -> Start -> Start Analysis & Synthesis. At this stage, a

correctly built project should have no errors or warnings.

(O Quartus Prime Standard Edition - E/FPGA/D: ab0/ProLab0_| - Prolab0 | i
File Edit View Project Assignments Processing Tools Window Help
O Hd | aliio} ProLab0_Fundamentals ~ - & & PEES @AVE
Project Navigator E Files ~|lams x| Top.bdf* (<]
Fles da Doc/ERawAsE-O173NNNDOo N~ FE a9
E? Topbdf : : : 2
oy iz
nnnnnnn
= = f;«*z i pin_name
pin_nam o s
ITasks Compilation MEI T
Task «
v P Compile Design
P Analysis & Synthesis
P Fitter (Place & Route)
B> Assembler (Generate programming filt
P Timing Analysis o o
< > |« >
x [Quartus Prime Tcl Console
A
i1
2
i1
=|Twoe ID Message
© 253020 Default device 10MO8DAF484C8G is automatically selected for the device family MAX 10
$| system(1)  Processing

Fig. 14: Quartus Prime window with an AND2 gate

639,149 0%  00:00:00

17. Next, you need to import the pin assignments from the gsf file that was previously copied to the
project directory. Go to Assignments -> Import Assignments... This step only needs to be

performed once during the project build.

O Import Assignments

Specify the source and categories of assignments to import.

File name: |E:fFPGAnydakt}fkafProLabeDE'IG_Lite.qsf

| | | Categories...

OK

Copy existing assignments into ProLab0 Fundamentals.qsf.bak befare importing

Advanced..

Help

Fig. 15: Import Assignments Window
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18. If the previous steps were completed successfully, the block diagram ports should display
information about the physical pin numbers of the FPGA device (Fig. 16).

(b Quartus Prime Standard Edition - E/FPGA/D: ab0/ProlLab0_f - ProLab_f

File Edit View Project Assignments Processing Tools Window Help

O n» ProLabo_Fundamentals = <~ &€ &2 @ L DAV R
Project Navigator iles clame < | Top.bdf B @ Compilation Report - ProLab0_Fundamentals
Files = D" BrQWADTEYOTTTTINNNDOON N g A S &
2 ropbat = = & > = = & & & & & & x
- iz
o i: i e LEDRIO
[Tasks Compilation r|=lie =
Task «
D Fitter (Place & Route)
B Assembler (Generate programming fil¢
» Timing An . .
< > |« >
= [Quartus Prime Tcl Console
A
i1
?
[] .
i1
=|[Tvoe ID Messaae
o
o Running Quartus Prime Analysis & Synthesis
o Command: quartus_map --read_settings_files=on --write_settings_files=off ProLab0_Fundamentals -c ProLabO_Fundamentals
i 18236 Number of processors has not been specified which may cause overloading on shared machines. Set the global assignment NUM_PARALLEL_PROCESSORS in your QSF to an appropriate valu
©® 20030Parallel compilation is enabled and will use 4 of the 4 processors detected
2« >
i System (2)  Processing (5)

593,105 4% »¢ 00:00:08

Fig. 16: Quartus Prime Window

19. Before compilation, you still need to set the unused FPGA ports to a high-impedance state. Go to
Assignments -> Device -> Device and Pin Options -> Unused Pins -> Reserve all unused pins: As
input tri-stated (Fig. 17).

O Device and Pin Options - ProLab0_Fundamentals X
Category:
General | unusedpis |

Configuration Specify device-wide options for reserving all unused pins on the device. To reserve individual dual-

purpose configuration pins, go to the Dual-Purpose Pins tab. To reserve other pins individually, use the
Unused Pins. Assignment Editor.

Dual-Purpose Pins -

Capacitive Loading Reserve all unused pins: | As input tri-stated =
Board Trace Model

/O Timing

Voltage

Pin Placement

Error Detection CRC

CVP Settings

Partial Reconfiguration

Programming Files

Description:

Reserves all unused pins on the target device in one of 5 states: as inputs that are tri-stated, as outputs
that drive ground, as outputs that drive an unspecified signal, as input tri-stated with bus-hold, or as
input tri-stated with weak pull-up.

Reset

OK Cancel Help

Fig. 17: Device and Pin Options Window
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20. To start the project compilation, click the Start Compilation button or select Processing -> Start
Compilation (Fig. 18).

(G Quartus Prime Standard Edition - E/FPGA/D: ab0/ProLabO._f - ProLab0_f

File Edit View Project Assignments Processing Tools Window Help

D  nfllo) ProLabo_Fundamentals ~| “ € E ¢ T FES @AV R
Project Navigator E Files ~lafme x| T & Compilation Report - ProLabo_Fundamentals - & DE10_Lite.gsf
Files (=] D" O 11 aNNNDOo N Nl a g &
E2 Topbdf 5 . - : i . .
A0 gﬁ;}’:ﬁb S LEDRIO
1. 3 Py -pw A8
ITasks Compilation MEI T
Task «
v P Compile Design
P Analysis & Synthesis
P Fitter (Place & Route)
B> Assembler (Generate programming filt
P Timing Analysis o o
< > |« >
x [Quartus Prime Tcl Console
A
i1
?
[=] o
i1
=|Twe ID Messaae ~
° .
o Running Quartus Prime Analysis & Synthesis
o Command: quartus_map --read_settings_files=on --write_settings_files=off ProLab0_Fundamentals -c ProLabO_Fundamentals
& 18236 Number of processors has not been specified which may cause overloading on shared machines. Set the global assignment NUM_PARALLEL_PROCESSORS in your QSF to an appropriate va
@ 20030Parallel compilation is enabled and will use 4 of the 4 processors detected
n © 12021 Found 1 design units, including 1 entities, in source file top.bdf o
Y PSS G-V FuV U TR S, PNVHC R S )
2« >
i System (3)  Processing (12)

@

tarts a new compilation 174,-3 100%  00:00:16

Fig. 18: Quartus Prime window before compilation

21. If the compilation was successful, you can proceed to program the FPGA device. To do this, select
the Programmer button on the toolbar or go to Tools -> Programmer. A window will appear as
shown in Fig. 19. Next, click the Add File... button and select the file with the *.sof extension from
the output_files subdirectory.

» Programmer - E;/FPGA/Dydaktyka/ProLab0/ProLab0_Fundamentals - ProLab0_Fundamentals - [Prolab0_Fundamentals.cdf] #5 O X

File Edit View Processing Tools Window Help

o Hardware Setup.. |No Hardware Mode: |JTAG X Progress:

[ Enable real-time ISP 10 allow background programming when available

e File Device Checksum Usercode Program/ Verify Blank- Examine Security Erase ISP
a
Configure Check Bit CLAMF
i st0p output files/ProL.. 10M50DAF484 0026D2F3 0026D2F3
8 Auto Detec
Delete
" Add File...
" Change File A
2l save Flle
| o E =
* Add Device| | |——pi } :
Wup ——
10MS0DAF 484
' pown . Too
N

Fig. 19: Programmer Window

-10 -
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22. If the Start button is inactive, select Hardware Setup... In the window that appears, ensure that

Currently selected hardware: USB-Blaster [USB-0] is displayed.

If the Start button is still inactive, it means that the FPGA device is either powered off, not
connected to the computer, or, in the case of using a virtual machine, the physical USB port is not
bridged with the operating system in the virtual machine. To program the device, click the Start

button.

“ Programmer - E//FPGA/MSWSiS/ProSilnikDC_DE10-Lite_Q18.1/ProDCMotor - ProDCMotor - [ProDCMotor.cdf]

File Edit View Processing Tools Window Help

o Hardware Setup... | | ns EEra gl =ne)|

[] Enable real-time ISP to allow background programming when available

Mode: JTAG X Progress:

100% (Successfgijji_ijl

¥ Auto Detec
Delete

% Add File...

W Start File Device Checksum Usercode Program/ Verify Blank- Examine Security Erase
Configure Check Bit
i st0p output_files/ProD... T0M50DAF484 00274270 00274270

ISP
CLAMF

| Change File

Sl save File

oI
* Add Device

YWup || e

10MSODAF484
' pown 0O

-~

Fig. 20: Programmer tool window after programming the device
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