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PROFINET IO is used for data exchange between PLC (I/O controllers) and
field devices (I/O devices). PROFINET IO uses the proven communication model and
application view of PROFIBUS DP and extends it by Ethernet as the communication
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application view of PROFIBUS DP and extends it by Ethernet as the communication
medium. Among other benefits, this provides a greater bandwidth and allows more
stations on the network. The PROFINET IO specifications define a protocol and an
application interface for exchanging I/O data, alarms and diagnostics and for
transmitting data records and logbook information.

To exchange I/O data and alarms, PROFINET IO is based directly on the
Ethernet protocol. This real-time (RT) solution allows response times in the range of 5
ms, which corresponds to today's PROFIBUS DP applications. If it has to be even
faster and if data exchange should be performed isochronously (IRT), a special chip
is used, which also supports switch functions. "Normal“ Ethernet communication is of
course also possible when using the chip. The solution consists in reserving
bandwidth for the isochronous data exchange and bandwidth for "the remainder."
Innovations have also been made with regard to the device description in that XML is
used for structuring the information.

For all that is new, however, the existing has not been forgotten or dispensed 
with. The integration of existing fieldbus devices will be performed via proxies, and
PROFIBUS profiles will also be available for PROFINET IO. PROFIdrive and 
PROFIsafe will be the first to be revised.
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PROFINET I/O is based on a consistent model of the IO device structure and
capabilities. An IO device may be modular and is composed of one ore more slots,
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capabilities. An IO device may be modular and is composed of one ore more slots,
which may have subslots. Each slot or subslot represents an IO module and has a
fixed number of input and output bits. The input data of the IO device is the sequence
of all inputs of slots and subslots, according to their position in the device. The same
holds for the output data.

Slot 0 and subslot 0 do not represent IO modules and have no IO data and it is
used to address the IO device. Subslot 0 is used to address its corresponding slot.

Also all diagnostic or alarm data reference slots or subslots.
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PROFINET nodes are integrated into projects using device description files. This
is a standardized type of file which describes the properties of the PROFINET nodes.

Configuration of a PROFINET IO System 4

is a standardized type of file which describes the properties of the PROFINET nodes.
The device description file for PROFINET is usually abbreviated “GSD file”. GSD
stands for “General Station Description” while the extension ML indicates the use of
XML).

A GSD file for a device contains standardized information on its properties. It is
important to use the correct GSD files in your PROFINET system. Each PROFINET
device has an individual device ID. The device ID is allocated by the manufacturer
and, in combination with the manufacturer ID allocated by the PROFIBUS user
organization it is globally unique for each device type. The GSD file has to match the
device ID of the configured device. The device ID consists of 16 bits. This information
can be retrieved from the GSD file.

� When using devices from different manufacturers, the relevant GSD files must be
imported to the configuration tool. This is usually done by simply copying the GSD
files in the relevant directory

� When using the GSD files, make sure that the used GSD file matches the version
of the PROFINET node. Otherwise some features may not be available to you.

� The GSD files of the used PROFINET nodes are available from the manufacturers.
Some of the files are also available for download via the website of the PROFIBUS
user organization at www.PROFINET.com.
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To allow a PROFINET device to be addressed as a node on Industrial Ethernet,
this device also requires an IP address that is unique on that network. The IP address
is made up of 4 decimal numbers with a range of values from 0 through 255. The
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is made up of 4 decimal numbers with a range of values from 0 through 255. The
decimal numbers are separated by periods. The IP address is made up of the
following:

● Address of the network and
● Address of the node (generally called the host or network node).

In addition to the IP address, a PROFINET IO device requires a network mask in
order to communicate in PROFINET. The notation of this so-called network mask is
identical to the notation of IP addresses. Networks are subdivided into individual
ranges using this network mask, also called subnet mask. The most common subnet
masks correspond to the network masks as shown in table.

Another way of subdividing networks into smaller logical segments is called
“subnetting”, which means that the network mask is modified according to a special
procedure. This makes sure that no direct communication between network nodes is
possible within a network unless these nodes are members of the same
“subnetwork”. As a consequence, the number of network nodes in a “subnetwork” is
reduced.

In most cases, addressing using the private class C address range is sufficient.
For special cases where a larger address range than provided in class C is required,
it is possible to switch to other classes. The described subnetting offers additional
possibilities for subdividing networks. This should only be done by qualified,
experienced personnel.
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Every PROFINET device is assigned a worldwide unique device identifier at the 
factory. This 6-byte long device identifier is the MAC address. The MAC address is 
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factory. This 6-byte long device identifier is the MAC address. The MAC address is 
consists of:

● 3-byte vendor identifier and

● 3-byte device identifier (consecutive number).
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Before an IO device can be addressed by an IO controller, it must have a device
name. In PROFINET, this method was selected because it is simpler to work with
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name. In PROFINET, this method was selected because it is simpler to work with
names than with complex IP addresses.

In their original delivery status, PROFINET IO devices do not have a device
name, but only a MAC address. This address is persistently stored in the device; it is
globally unique and can usually not be changed.

� Some manufacturers have proprietary tools which allow for a MAC address to
be changed in case a device has to be replaced.

� Many PROFINET devices have the MAC address printed on the housing or on
the rating plate.

A PROFINET IO device can only be addressed by a PROFINET IO con troller
after having been allocated a device name , usually for the acyclic transfer of
planning data (among others the IP address) or when starting the PROFINET IO
device. Cyclical exchange of data is realized using the MAC address, if the
PROFINET IO Controller and the PROFINET IO-Device are placed in the same
subnet.
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By downloading the hardware configuration, the valid IP address is obtained for
the IO devices. This assignment is implemented via the specific "device name". The 
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the IO devices. This assignment is implemented via the specific "device name". The 
device names are saved on the Micro Memory Card to support module replacement 
without a PG/PC.

If you remove the memory card / C-Plug from a PROFINET controller and plug it 
into a different PROFINET device, you will transfer the device-specific information 
and the IP address to the device.

If an IO device has to be replaced in its entirety due to a device or module defect, 
the IO controller automatically assigns parameters and configures the new device or 
module. The cyclic exchange of user data is then restarted. In addition to this, before 
the network on of the IO device, the Micro Memory Card with the valid name is 
removed from the faulty IO device and added to the exchanged device.

The MMC card / C-Plug allows modules to be replaced without a programming 
device/PC in the event of a fault in a PROFINET device. You can also transfer the 
device data from the PC/PC directly to the MMC (for the ET200S/PN IO device, for 
example).
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Setting up and operating an automation system with STEP 7 or NCM PC involves the following 
basic steps:
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1. Planning the system - The system planner specifies the scope of functions of the automation 
system and the type and scope of the implemented automation devices

2. Configure the system with STEP 7 -The configuration engineer creates the project by:

– Opening an available or setting up a new project;

– Importing new PROFINET devices into the hardware catalog using GSD files, if necessary;

– Inserting more PROFINET devices in the project;

– Networking the automation devices in the network view;

– Assigning device names (not necessary for IO devices where the PROFINET Function "Device 
replacement without removable media / PD" has been configured);

– Creating the user program;

– Checking the configuration;

3. Commissioning and testing the plant -The commissioning engineer performs the following tasks:

– Commissioning the automation devices

– Downloading the project data to the automation devices of the system. The device name is then 
assigned to a real device with a MAC address.

– Revising the configuration and / or the user program in STEP 7, if necessary

– Testing the system

4. Operating the plant - The plant operator performs the monitoring and changing the process data 
online, running diagnostics on the system; operator control and monitoring

5. Performing maintenance and modifications.
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Creating a Project: Select the menu options File -> New or the symbol in the 
toolbar to open the "New" dialog box for creating a new project or a new library. Enter 
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toolbar to open the "New" dialog box for creating a new project or a new library. Enter 
the project name in the "Name" box and click the "OK" button to confirm.

Notes

1. The "Storage location (path)" displays the path that was preset in the 
SIMATIC Manager under Options -> Customize. 

2. As of STEP 7 V3.2, the 'New Project' Wizard helps you create a new 
project.

Insert Station: You insert a new station in the current project by selecting the 
menu options Insert -> Station -> SIMATIC 300 Station or SIMATIC 400 Station.

You can then change the name that is automatically given to this station -

"SIMATIC® 300 (1)" - to one of your choice.

HW Config tool helps you configure, assign parameters to and diagnose the 
hardware. To start the HW Config tool:

• select a hardware station in the SIMATIC Manager and choose the Edit --> 
Open Object menu or

• double-click the hardware object.



SIEMENS PROFINET Co-operative Network Training

Hardware configuration: is a window in the "HW Config“ application you use for 
inserting components from the "Hardware Catalog" window. The title bar of this 
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inserting components from the "Hardware Catalog" window. The title bar of this 
window contains the name of the project and the station name. 

To open the "Hardware Catalog":

• select the View -> Catalog menu or

• click the icon in the toolbar.

If “Standard” is selected as the catalog profile, all racks, modules and interface
modules are available in the "Hardware Catalog" window.

You can create your own catalog profiles containing frequently used elements by
selecting the menu options Options -> Edit Catalog Profiles.

You can add PROFINET IO Device that do not exist in the catalog later on. To
add the device, you use GSD files that are provided by the manufacturer of the
device. To include the Device in the hardware catalog, use the Options -> Install New
GSE Files menu and then Options -> Update Catalog. You will find the new devices in
the catalog under PROFINET IO, Additional Field Devices.
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Generating a Controller Configuration: This means specifying how the modules
are to be arranged in the rack. This configuration specified by the user is referred to
as the setpoint configuration.
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as the setpoint configuration.
When you open a SIMATIC 300 station in the hardware catalog. Opening the

"RACK-300" contains an icon for a DIN rail. You can insert this in the "Hardware
Configuration" window by double-clicking it (or using drag & drop).

Two rack component lists then appear in the two-part window: a plain list in the
top part and a detailed view with order numbers, MPI addresses and I/O addresses
in the bottom part.

If a load current power supply is required, you insert the appropriate "PS-300“
module at slot No. 1 in the list with a double click or by drag & drop.

You select the CPU from the "CPU-300" catalog, for example, and insert it in slot 2
with a double click.

Slot 3 is reserved as the logical address for an interface module (for multi-tier
configurations). If this position is to be reserved for installation of an IM at a later date
in the actual hardware configuration, a DM370 dummy module must be inserted.

From slot 4 onwards you can insert a choice of up to 8 signal modules (SM),
communications processors (CP) or function modules (FM).
You insert modules in a selected slot in the list by double-clicking the module you

want in the catalog.
Or you can insert modules anywhere in the list using drag & drop.
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Slot Numbers The slot numbers in the rack of an S7-300™ simplify addressing
in the S7-300™ environment. The position of the module in the rack determine the
first address on a module.
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first address on a module.
Slot 1 - Power supply . This is the first slot by default. A power supply module is

not absolutely essential. An S7-300™ can also be supplied with 24V directly.
Slot 2 - Slot for the CPU.
Slot 3 - Logically reserved for an interface module (IM) for multi-tier

configurations using expansion racks. Even if no IM is installed, it must be included
for ddressing purposes. You can physically reserve the slot (such as for installing an
IM at a later date) if you insert a DM370 dummy module.

Slots 4-11: Slot 4 is the first slot that can be used for I/O modules,
communications processors (CP) or function modules (FM).

Addressing examples:
• A DI module in slot 4 begins with the byte address 0 .
• The top LED of a DO module in slot 6 is called Q8.0 .

Note
1. Four byte addresses are reserved for each slot. When 16-channel DI/DO

modules are used, two byte addresses are lost in every slot!
2. With the S7-300™ (CPUs with integrated DP interface) and with the S7-

400™, you can assign parameters to the starting addresses of the modules
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Select the module, the PROFINET interface of which should be configured. This 
is shown exemplarily by the CPU 315F-2 PN/DP control.
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is shown exemplarily by the CPU 315F-2 PN/DP control.

Call the "Properties" dialog box of the PROFINET interface or its port(s) by 
double-clicking:

• PN-IO (PROFINET interface X2)

• Port 1 (port 1 of interface X5: X5 P2)

• Port 2 (port 2 of interface X5: X5 P2)

Assign a name to IO controller

The window with the Ethernet properties of the CPU opens. Enter the desired IP 
address and Subnet mask. Click on New to create a new Industrial Ethernet subnet. 
Use the suggested entries and confirm all windows with OK.

The CPU has been inserted into the S7 controller with PROFINET IO network.
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The following PN interface parameters can be edited or displayed via the describing tab:

• General
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• General

– Name of the interface of the IO controller

– IP address

– Subnet mask

– Gateway 

• Addresses

– Diagnostics address of the interface of the IO controller and of the IO controller itself

• PROFINET

– Send clock (can only be edited in the "Synchronization" tab, if the PN device is not 
configured in a sync domain)

– IO communication traffic of PROFINET IO and PROFINET CBA

– Call OB 82 for communication alarm

• Synchronization

– Synchronization role

– Name of the sync domain (can be edited in the PROFINET IO domain management)

– RT class and IRT option

• Time synchronization

– NTP process with update interval
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In the hardware catalog, navigate to PROFINET IO -> Network Components ->
SCALANCE X-200 -> SCALANCE X208 Select order number and version of your
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SCALANCE X-200 -> SCALANCE X208 Select order number and version of your
switch.

Use drag & drop to move it to the PROFINET network.
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Double-click on the module to open the Properties dialog box of the module. In
this dialog box, you can enter
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this dialog box, you can enter

� the device name,

� the GSD XML file to be used and

� the IP address to be assigned.

To change the device name, enter the new name in Device Name.

Use the Change Release Number… button to select the GSD XML file to be used
by the system. It is recommended that the most current version be used. Close the
window with OK

Use the Ethernet… button to enter the IP address of the SCALANCE X208. The
system specifies a free IP address in the STEP7 project, it can be adjusted as
desired. The address is dynamically assigned during startup of the controller. Close
the dialog boxes with OK.
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1. To open dialog with the general settings, select the device whose settings you 
want to change. In the lower half of the station window, there is a detailed view of 
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want to change. In the lower half of the station window, there is a detailed view of 
the selected device.

2. Double-click on slot 0 to open the properties dialog of the PROFINET interface. As 
an alternative, the properties dialog can also be opened by right-clicking on slot 0 
and selecting the "Object Properties" entry from the context menu.

3. Then select the "Parameters" tab. Here, you can make the following settings:

Redundant power supply:

� Not monitored -The failure of one of the two power supplies does not 
cause an alarm to be generated.

� Monitored -The failure of one of the two power supplies causes an alarm.

C-PLUG

� Not monitored -No alarm results from a C-PLUG error.

� Monitored - A C-PLUG error causes an alarm.

4. On the Diagnostic Address, the Switch reports for synchronization errors or media 
redundancy errors of the IO controller using this diagnostic address providing that 
the IO controller supports this function.
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1. Open the properties dialog of the PROFINET interface by double-clicking on the PN-IO
slot in the lower half of the station window (detailed view of the selected device). As an
alternative, the properties dialog can also be opened by right-clicking on the PN-IO slot
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alternative, the properties dialog can also be opened by right-clicking on the PN-IO slot
and selecting the "Object Properties" entry from the context menu.

2. And go to the "Media Redundancy" tab. You can set the following parameters in the
"MRP configuration" box to configure MRP for the device:

● Domain
- All devices configured in a ring with MRP must belong to the same redundancy domain. A

device cannot belong to more than one redundancy domain. Select the same domain for
all devices of your ring from the drop-down list ("mrpdomain-1").

- If you leave the setting for "Domain" as the factory set "default-mrpdomain", the factory
settings for "Role" and "Ring ports" also remain active.

- The MRP settings remain in effect following a restart of the device or following a power
down and hot restart.

● Role The choice of role depends on the following uses:
- You want to use MRP in a ring topology only with Siemens devices and without

monitoring diagnostic interrupts - Assign all devices to the "default-mrpdomain". The
device that actually takes over the role of redundancy manager, is negotiated by Siemens
devices automatically.

- You want to use MRP in a ring topology that also includes third-part devices or you want
to receive diagnostic interrupts relating to the MRP status from a device (see "Diagnostic
interrupts") - Select the "Manager" role for one device (and one only) that will be
redundancy manager in the ring. With all other devices in the ring topology, select the role
of "Client".

- You want to disable MRP - Select the option "Not node in the ring" if you do not want to
operate the device within a ring topology with MRP.
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� Ring port 1 / ring port 2 - Here, select the port you want to configure as ring port
1 and ring port 2. The drop-down list shows the selection of possible ports for each
device type. If the ports are specified in the factory, the boxes are grayed out.
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device type. If the ports are specified in the factory, the boxes are grayed out.
� Diagnostic interrupts Select the "Diagnostic interrupts" option, if you want

diagnostic interrupts relating to the MRP status to be output on the local CPU. The
following diagnostic interrupts can be generated:

o Wiring or port error - Diagnostic interrupts are generated if the following
errors occur at the ring ports:

� A neighbor of the ring port does not support MRP
� A ring port is connected to a non-ring port
� A ring port is connected to the ring port of another MRP domain.

o Interruption / return (redundancy manager only).If the ring is interrupted
and when the original configuration returns, diagnostic interrupts are
generated. The occurrence of both interrupts within 0.2 seconds indicates
an interruption in the ring.
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Prioritized startup
Select the "Prioritized startup" check box to speed up the startup of the IO device

(earlier entry into data exchange between controller and device). The check box can
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(earlier entry into data exchange between controller and device). The check box can
only be selected in the following situations:

� The IO controller you are using can prioritize selected IO devices during
startup.

� The IO device you are using supports prioritization.
Within a PROFINET IO system, you can only prioritize a certain maximum number

of IO devices that depends on the IO controller you are using. To achieve the fastest
startup times, you should also keep the following points in mind:

� In the port properties of the IO device, select a concrete transmission
medium (for example TP/ITP at 100 Mbps full duplex) and select the
"Disable autonegotiation" check box. This can save up to three seconds
startup time. Note: This requires, in particular, the use of dedicated cable.

� If supported by the IO device, use a fixed IP address assignment for the IO
device. You can do this by deselecting "Assign IP address via IO controller"
on the IO device and initializing the IO device using the "Primary Setup
Tool" or the "Lifelist".

� Where possible, use fast starting IO modules in modular IO device (for
details, refer to the relevant module description).
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Procedure
1. Double-click on the required port to open its properties dialog. As an alternative, 

the properties dialog can also be opened by right-clicking on the relevant port and 
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the properties dialog can also be opened by right-clicking on the relevant port and 
selecting the "Object roperties" entry from the context menu.

2. Then select the "Topology" tab.
Partner-Port

Here, you can configure the appearance of the topology to be monitored. To do 
this, select the port of another device from this configuration in the "Partner Port" 
menu that is connected to the currently selected port:

● if you want alternating ports to be monitored, select the entry "Alternating 
partner port".
● If you do not want to monitor the topology, select "Any partner". This is also 

the default setting.
Alternating partner ports

Here, select all the ports you want to be monitored as alternating partner ports.
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Connection: If necessary, you can enter fixed port settings here. By default,
"Automatic setting" is already selected. Usually, this setting will provide smooth,
problem-free communication.
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problem-free communication.
Automatic settings: Recommended default setting for the port. The transmission

settings are automatically "negotiated" with the partner port. "Autonegotiation" is also
automatically enabled with this setting.

Automatic settings (monitor) : diagnostics. Examples of port diagnostics: the link
status is monitored, in other words, diagnostic information is generated for link down
and the link power budget is monitored for fiber-optic ports.

TP / ITP at x Mbps full duplex (half duplex): Sets the transmission speed and
full duplex / half duplex mode. The effect depends on the setting "Disable auto-
negotiation “.

Disabled: Depending on the module type, the "disabled" option may be offered
in the drop-down list. You then, for example, prevent access to an unused port for
security reasons.
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Drag-and-drop IM151-3 PN from the PROFINET IO > I/O > ET 200S catalog to
the PROFINET IO system.
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the PROFINET IO system.

From the hardware catalog, drag-and-drop the various ET 200S modules into the
configuration table, according to the physical installation of the PROFINET IO
devices.

In the field devices (IO Devices) of type ET 200S requires placement of power
modules in accordance with the required input / output configuration
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Double-click on the IM 151-3 station to open the Properties window of the head
module. In this window, you can adjust the IP address or the device name. The
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module. In this window, you can adjust the IP address or the device name. The
device name Siemens-Coupler is used here. Confirm with OK.

The CPU 31x-2 PN /DP will automatically assign further IP addresses in
ascending numerical order starting from the configured base IP address (IO
controller) provided this option is not deactivated.

The IP address can be changed within the permissible range in the "Edit IP
addresses" window, if necessary.
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1. Double-click on slot 0 to open the properties dialog of the PROFINET interface. As 
an alternative, the properties dialog can also be opened by right-clicking on slot 0 
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an alternative, the properties dialog can also be opened by right-clicking on slot 0 
and selecting the "Object Properties" entry from the context menu.

2. Then select the "Parameters" tab. Here, you can make the following settings:

Bus length

≤ 1 m: The default setting for the maximum bus length is 1 m.

> 1 m: The bus length of the ET 200S is > 1 m and can be up to 2 m. However, 
this setting will increase the response time of the ET 200S.

Interference frequency suppression

The interference frequency suppression parameter applies to all analog electronic 
modules. This parameter is also used to specify the integration and conversion 
time of the various modules. 

See the technical data for the analog electronic modules.

Reference junction slot -This parameter allows you to assign a slot (none, 2 to 63) 
with a channel for measuring the reference temperature (calculation of the 
compensation value).

Reference junction input -This parameter can be used to set the channel (0/1) for 
measuring the reference temperature (calculation of the compensation value) for 
the assigned slot.
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Synchronization tab displays the synchronization properties of the IO controller.
Synchronization Role: The role of the PROFINET device with respect to synchronization:

A "sync master" transmits sync signals at equal time intervals; "sync slaves" synchronize
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A "sync master" transmits sync signals at equal time intervals; "sync slaves" synchronize
themselves with this signal. “Not synchronized “ is selected, if the device is not to take part
in synchronized data exchange (IRT).

In the synchronization role "not synchronized ", the RT class "RT" is set. If "sync master"
or "sync slave" is selected as the synchronization role, RT class "IRT" is set automatically.

The name of Sync Domain matches the name specified in the IO controller:
With RT class you can only select classes supported by the device. The following real-time
classes are available:

� RT: Transfer of data in prioritized Ethernet frames, not in isochronous mode. The
required bandwidth is in bandwidth reserved for cyclic data.

� IRT: Transmission of data in isochronous mode with high stability for time-critical
applications (for example motion control). The required bandwidth is in bandwidth
reserved for cyclic data.

� IRT*: Transmission of data in isochronous mode with high stability for time-critical
applications (for example motion control). The topology must be planned.

IRT option can be selected only for IRT classes. The two available options differ in terms
of deterministic:

� High flexibility : A fixed bandwidth is reserved in the transmission resources for
real-time communication. The "high flexibility" allows simple planning and
expansion of the plant.

� High performance : A fixed bandwidth is reserved in the transmission resources
for real-time communication. Topology planning optimizes the data traffic and
speeds it up further. The "high performance" option requires configuration of the
topology.
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Mode:

The following can be set:
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The following can be set:

� “Automatic": STEP 7 finds the best solution for the user. The update time
is kept as short as possible and as high as necessary, so that no errors or
warnings can occur.

� "fixed update time": The update time of the IO device is set to a fixed
value by the user. With this setting, errors are possible in the consistency
check.

� "fixed factor": The user sets the reduction ratio with which the IO device is
updated (for example, factor 2 for updating on every second clock pulse
sent).

Factor - Reduction ratio.

Number of accepted update cycles with missing IO data - To make adaptations
in problem situations, you can change the default number of accepted update cycles
with missing IO data (for example during commissioning). This action will also
indirectly change the watchdog time. Exceeding the watchdog time will result in an
error reaction (the IO device switches its outputs to a safe state).

Watchdog Time - Product of "Update Time" x "Number of accepted update cycles
with missing IO data". Maximum watchdog time: 1.92 seconds.
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Prioritized startup 
Select the "Prioritized startup" check box to speed up the startup of the IO device
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Select the "Prioritized startup" check box to speed up the startup of the IO device
using device-internal functions (data exchange between controller and device starts
earlier).

The check box can only be selected if the IO controller you are using can prioritize
selected IO devices during startup.

Within a PROFINET IO system, you can only prioritize a certain maximum number
of IO devices that depends on the IO controller you are using.

To achieve the fastest startup times, you should also keep the following points in
mind (in some situations, the individual actions will speed up the startup even without
selecting the "Prioritized startup" check box):

� In the port properties of the IO device, select a concrete transmission
medium (for example TP/ITP at 100 Mbps full duplex) and select the
"Disable autonegotiation" check box. This can save up to three seconds
startup time.

Note: This requires, in particular, the use of dedicated cables.
� If supported by the IO device, use a fixed IP address assignment for the IO

device. You can do this by deselecting "Assign IP address via IO controller"
on the IO device and initializing the IO device using the "Primary Setup
Tool" or the "Life list".

� Where possible, use fast starting IO modules in modular IO device (for
details, refer to the relevant module description).
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Setting the communication ports is done by filling in the tables "Topology" and "Options". 
See slides 23 and 24 

Port Interconnection tab shows the name of the local port.
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Port Interconnection tab shows the name of the local port.
Partners tab - Select the required partner port from the "Partner port" drop-down list. You 

can interconnect devices under "Partner port" if:
� The port is connected to the Ethernet subnet
� Other PROFINET devices are connected to a port on the subnet
� The devices support topology configuration

In Option tab/Connection - you can enter fixed port settings here. By default, "Automatic 
setting" is already selected. Usually, this setting will provide smooth, problem-free 
communication. 

Boundaries are the boundaries for the transfer of certain Ethernet frames. The following 
boundaries can be set at a port:
�"End of sync domain" - Sync frames transferred to synchronize nodes within a sync 
domain are not forwarded. 
�"End of detection of accessible nodes" -DCP frames for detecting accessible nodes are 
not forwarded. Ports downstream of this port can then no longer be displayed in the list of 
accessible nodes. Ports downstream from this port can no longer be reached by the 
controller. 
�"End of topology discovery" - LLDP frames for topology discovery are not forwarded.

Note the following restrictions:
� The individual check boxes can only be set if the port supports the corresponding feature.
� If a partner port was selected for the port, the following check boxes cannot be set:

- "End of detection of accessible nodes"
- "End of topology discovery"

� If the "Disable autonegotiation" check box was selected, none of the boundary check boxes 
can be selected. 
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Disable autonegotiation check box can only be controlled when you have 
selected a concrete medium (such as TP/ITP with 100 Mbps full duplex). The check 
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selected a concrete medium (such as TP/ITP with 100 Mbps full duplex). The check 
box has no effect with the automatic setting.

When the check box is selected, the defined setting of the port is forced, such as 
required for a quick start of the IO device. You need to ensure that the partner port 
has the same settings since the following functions are disabled with this option:

� Autonegotiation (operating parameters of the connected network are 
detected and the data transmission speed and transmission mode are 
optimally set)

� Autocrossover - automatic crossover of send/receive lines (depending on 
the devices involved)

� Autopolarity (also depending on the devices)

When the “ Disable auto-negotiation" option is enabled:

� Make sure that you use the correct cable (see below)! Even with this
setting, the port is still monitored.·

� If the above option is disabled you can use both crossover and patch
cables. The transmission rate and duplex mode are set automatically and
monitored as in "Automatic settings (monitor)". If the automatic settings do
not match the selected setting, a diagnostic event is generated.
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Usually GSD files PROFINET IO devices are not manufactured by SIEMENS, are 
not included in the hardware catalog of HW Config Tool. To add the device, you use 
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not included in the hardware catalog of HW Config Tool. To add the device, you use 
GSD files that are provided by the manufacturer of the device. To include the Device
in the hardware catalog, use the Options -> Install New GSE Files menu and then
Options -> Update Catalog. You will find the new devices in the catalog under
PROFINET IO, Additional Field Devices.

From the hardware catalog, drag-and-drop the various IO Device modules into 
the configuration table, according to the physical installation.
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Double-click on slot 0 to open the properties dialog of the PROFINET interface. 
The "Parameters" tab shows you the parameters for the IO device. These 
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The "Parameters" tab shows you the parameters for the IO device. These 
parameters, their representation and the default settings are contained in the GSD file 
for the IO device. For explanations of each parameter, refer to the manual for the IO 
device.

See  slide 29 for setting IO Cycle parameters
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Double-click on slot 0 to open the properties dialog of the PROFINET interface.
The "Parameters" tab shows you the parameters for the IO device. These
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The "Parameters" tab shows you the parameters for the IO device. These
parameters, their representation and the default settings are contained in the GSD file
for the IO device.

For explanations of each parameter, refer to the manual for the IO device.
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The IE/PB Link PN IO is a stand-alone component for connecting Industrial 
Ethernet to PROFIBUS DP. By means of the IE/PB Link PN IO as proxy, the existing 
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Ethernet to PROFIBUS DP. By means of the IE/PB Link PN IO as proxy, the existing 
PROFIBUS slaves can continue to be used and integrated into a PROFINET 
application.

As a PROFINET IO proxy, the link connects PROFIBUS DP slaves to PROFINET 
IO controllers through real-time communication (RT) with the PROFINET standard. 
Additional functions of IE/PB Link PN IO are S7 routing and data record routing over 
PROFIBUS DP.

S7 routing supports cross-network PG/OP communication. All S7 stations on 
Industrial Ethernet and on PROFIBUS can be remotely programmed from the 
programming device. SIMATIC PDM PROFIBUS field devices can be parameterized 
and diagnosed by means of data record routing.

The IE/PB Link PN IO has an internal flash memory for storing the configured 
database. For replacement of the device without a programming device in the case of 
servicing, the device can be operated with a C-PLUG as a swap medium. The C-
PLUG is located in a slot on the rear of the IE/PB Link PN IO and is then simply 
plugged into the replacement device.

If a C-PLUG is plugged in , the configured database is always saved on it. The 
internal flash memory is only used when a C-PLUG is not plugged in. If a C-PLUG 
is plugged in that has invalid formatting for the IE/PB Link PN IO or that contains a 
faulty database, the device will remain in the STOP state. The CPLUG must then be 
reformatted using NCM diagnostics or reloaded with an error free database.
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Procedure:

1. Insert an IE / PB Link PN IO in your hardware configuration. Assign the
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1. Insert an IE / PB Link PN IO in your hardware configuration. Assign the
PROFIBUS standard master address “2“ and insert a DP master system. Accept
all default settings.
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Procedure:

2. In the usual manner, assign a device name and an IP address to the IE/PB link.
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2. In the usual manner, assign a device name and an IP address to the IE/PB link.
Check this using the menu command PLC -> Ethernet…

3. Check accessibility of the IE/PB link using the PING command.

4. After downloading the configuration, the CPU automatically assigns the configured
IP address during start-up of the IE/PB link. If the subnets are correctly configured
and the configuration complies with the actual configuration of the IO device, the
IO device is ready for cyclic data transfer on the IE and DP subnet.

Note

� The IE/PB Link PN IO can be used either as a PROFINET IO device or as a
network transition.

� When it is used as a PROFINET IO device, the device name is saved retentively
in the C-PLUG. The configured database is transferred whenever the PROFINET
IO Controller starts up and is saved in temporary memory. If the IE/PB Link PN IO
is only used as a network transition, the configured database is transferred using
the download function of STEP 7.
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General notes: The short ID is entered as the device name in the "General" tab 
sheet where it can be changed. In the current PROFINET IO, the highest unassigned 
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sheet where it can be changed. In the current PROFINET IO, the highest unassigned 
number is always selected. The consistency check of the hardware configuration 
ensures that numbers are uniquely assigned.

In Options tab sheet, two parameters can be set for field devices: time 
synchronization and data record routing. 

Time synchronization - specifies whether the time transferred from the time-of-
day transmitter will be accepted by the IE/PB Link data record routing. When the 
option is deactivated, the link uses an internal system clock.

Device numbers: 

�Addresses are assigned to the DP slaves by the PROFINET IO controller using the 
PROFINET IO device number in the same manner as IO devices. 

�The tab sheet initially displays the automatically assigned device number of the DP 
slave and it can be edited here. The consistency check of the hardware configuration 
ensures that numbers are uniquely assigned.

�Multiple assignment of device numbers can occur when PROFIBUS addresses are 
assigned and automatic incrementing of the device number is set.

Diagnostics: The diagnostics can only be activated when the programming 
device can access the IE/PB Link online. NCM diagnostics can be started as a 
standalone program by clicking the "Run" button.
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Addresses are assigned to the DP slaves by the IO controller using the

PROFINET device number in the same manner as IO devices. STEP 7 tries to assign 

Configuration of a PROFINET IO System 41

PROFINET device number in the same manner as IO devices. STEP 7 tries to assign 
the same numbers when adding DP slaves to the master system.

Within a PROFINET IO system, all the device numbers must be unique.
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Open the window with the PG/PC-interface settings by selecting Options -> Set
PG/PC Interface and Select the network card you are using.
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PG/PC Interface and Select the network card you are using.

By clicking the button "Network properties..." you will reach the Control Panel of 
Windows, "Network Connections" window (Start taskbar -> Control Panel ->
Network Connections ). Here you can access the settings of the network
components of your PC
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The following example describes how you can set the IP address. The setting in
the field "Primary network login" has no effect on the planned change of IP address. 
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the field "Primary network login" has no effect on the planned change of IP address. 
Proceed as follows to change the IP address:

� Select the "TCP/IP" network protocol in the list box “This connection uses the
following items".

� Click the "Properties" button. The window “Internet Protocol Properties" 
appears for TCP/IP.

� Select the "General" tab and the option "Use the following IP address".

� Enter the required address and the subnet in the field "IP address".
(192.168.100.99 and subnet mask 255.255.255.0)

� Confirm all open windows with OK 
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If the CPU 31x-2 PN/DP is connected to the PG/PC by means of a "cross-over cable" 
or through the SCALANCE X208 switch, the CPU can be accessed through the 
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or through the SCALANCE X208 switch, the CPU can be accessed through the 
Industrial Ethernet (IE) interface. Use the function "Accessible nodes" in SIMATIC
Manager for this purpose and check the contents of the block container.



SIEMENS PROFINET Co-operative Network Training

The IP addresses of the IO devices are generated by STEP 7 and assigned to the IO
devices when the CPU starts up (see slide 8).
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In addition to this, special (independent ) IO devices, e.g. SCALANCE X , S7 300 and
CPs, support an option for assigning the IP address not from the IO controller during the
startup.

This procedure can be done in three ways for the IO controller :

�By direct recording of the project in MMC;

�By loading the hardware configuration in MPI or PROFIBUS interface;

�By the function Edit Ethernet node on the HW_Config Tool.

If your PROFINET device is equipped for a memory card (MMC), plug the MMC into your
programming device/PC and save the hardware configuration together with the configured IP
address on the MMC. Then insert the MMC into the PROFINET device. When you plug in the
MMC, the PROFINET device automatically adopts the IP address.

If your PROFINET device has an MPI or PROFIBUS DP interface, connect your
programming device directly to the PROFINET device via the MPI or PROFIBUS DP
interface. From STEP 7, assign an IP address to the device (actually assigned when the
hardware configuration is downloaded).

In the HW Config , select PLC -> Ethernet -> Edit Ethernet Node . The interface of the
PD/PC must be set to TCP/IP (Auto) mode.

To select the IO Controller by its MAC address, click Browse ... button, to start the
search for participants in the network.

New dialog with all the nodes that were found in the network appears. Select CPU
(device type: S7-300 ) and click OK. Appears known box "Edit Ethernet node" with the
selected MAC address
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Here, you can assign an IP address and IP parameters to a module the first time or 
you can reassign the IP address and IP parameters. You can also specify whether or 
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you can reassign the IP address and IP parameters. You can also specify whether or 
not the IP address will be obtained from a DHCP server.

The module is then accessible over the IP address set here, as an example for 
downloading project engineering data or for diagnostics.

If you operate a device as a PROFINET IO device, you can also assign the 
PROFINET device name here. Remember, however, that the device name should 
ideally be set in the Properties dialog so that it is stored in the project engineering 
data.

For setting up the IP configuration you can select from the following 
alternatives :

Use IP parameters - If you opened the dialog based on a selected module, the IP 
address already has the values configured for the module. Otherwise, you must 
enter the IP address, subnet mask and if applicable the gateway.

Obtaining the IP address from a DHCP server:

� If you select this option, the IP address is obtained from a DHCP server.

�Depending on the selected option, the DHCP server is informed for the MAC 
address for the CP, the device name, or the client ID that you can enter here.

�The client ID is a string with a maximum of 63 characters. Only the following 
characters can be used: a-z, A-Z, 0-9 and - (dash)

� If you specify here that the DHCP server should obtain the IP address using a 
device name, you must first assign the device a device name.

Click the "Assign IP Configuration" button.
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In their original, delivered condition, IO devices have no device names. IO
devices can be addressed by an IO controller only after having been assigned a
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devices can be addressed by an IO controller only after having been assigned a
name by a programming device (PG)/PC, such as for transmitting configuration data
(including the IP address) at startup or for the exchanging user data in cyclic
operation.

To assign the configured device name to an IO device online, select the menu
command PLC > Ethernet > Assign Device Name .

The procedure is performed in the following sequence:

- Desired device is selected from the central window;

- From the drop down menu select the corresponding name that exists in the
hardware configuration of the system;

- The choice is confirmed by pressing the "Assign Name“.

When the system has multiple identical devices to identify them can use the
function "Node Flashing Test ".

You can also assign a device name with the menu command PLC > Ethernet >
Edit Ethernet Node ; however, the device name should be set in the Properties dialog
of an IO device so that it is stored in the configuration data.

After you have configured the whole IO system, you now have to download this
configuration to the CPU.

Before starting the download, you should perform a consistency check in order to
have the configuration checked for addresses that have been used twice and names
that are not unique. Use the function "Verify Device Name".
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Find out if the CPU can receive the download for the first time via the
PROFINET interface. If not, you will then have to first download the
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PROFINET interface. If not, you will then have to first download the
hardware configuration via the MPI interface.

The following description of the procedure presumes that there is a connection
existing between the programming device (PG) and the CPU via Ethernet.

1. In the project window, select the user program or the blocks you want to
download.

2. Select the modules to be downloaded to.

3. If necessary, in the "Select Station Address" dialog box, click the "Display" button
to display the modules that are actually accessible (including the CPU receiving
the download with its current IP address or its MAC address if an IP address is still
not available).

4. In the accessible modules, select the CPU to receive the download .
This module is then displayed in the "Enter connection to target station" field.

5. Start the download by clicking the "OK" button. During this process, the CPU (i.e.
the IO controller) also gets its configured IP address assigned to it.
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After loading the project data, switch the IO controller from STOP to RUN mode 
to establish communication between the IO controller and the PROFINET nodes.
After initialization, the error free PROFINET IO devices are signaling operational
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After initialization, the error free PROFINET IO devices are signaling operational
readiness. You are able to check the operational status using the planning software
by means of the supervisor. Some PROFINET nodes allow you to determine their
status e.g. by means of LEDs. 

If the red BF 2 LED (Bus Fault 2) flashes on a CPU 31x-2 PN IO, a device is 
faulty somewhere in the PROFINET IO system.

The LINK and RX/TX LEDs are located under the cover. A continuous green light 
on the LINK LED indicates a functional connection to the next network node. If the 
LED is not lit, a connection is interrupted. The yellow RX/TX LED indicates data 
communication via the interface.

Faulty devices are indicated by the SF LED lit in red.
During start-up, the red BF LED flashes, faulty connections to the next network 

node are indicated by continuous red light.
If the IO controller is in RUN mode, the PROFINET nodes should no longer 

indicate any communication problems.
In case if any stations are indicating communication problems at this stage, 

additional checks should be undertaken, e.g.:
• Device type correctly configured?
• Device configuration OK / Device name correctly configured? 

For geographic location of the devices in the field, flashing of the Link LEDs can 
be activated in the same manner as for the controllers. The Link LED is located under 
the covers of ET 200S PN and IE/PB LINK PN IO.
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