Narzędzia użytkownika

Narzędzia witryny


swo:instalacja_eclipse_cdt

Instalacja Eclipse i CDT (Windows)

CDT (C/C++ Development Tooling) to zestaw narzędzi pozwalających na tworzenie programów w C/C++ w środowisku Eclipse.

Dystrybucja Eclipse jednak nie zapewnia takich programów, jak kompilator, linker, make, itd, ale dostosowuje się do do zewnętrznej instalacji zapewniając predefiniowane adaptery (Toolchain).

Dla środowiska Windows dostępne są między innymi:

  • MinGW + MSYS
  • Cygwin
  • Visual Studio

Opisana zostanie instalacja MinGW…

Instalacja MinGW

Należy pobrać MinGW ze strony http://sourceforge.net/projects/mingw/files/ oraz przeprowadzić instalację zgodnie z opisem w http://www.mingw.org/wiki/InstallationHOWTOforMinGW.

Podobne opisy są tu: http://max.berger.name/howto/cdt/ar01s03.jsp#wincompiler oraz tu: https://www.banym.de/eclipse/install-eclipse-cdt-on-windows-7

  • Zmienna środowiskowa PATH Po przeprowadzniu instalacji należy dodać katalog <MinGW>\bin oraz <MSYS>\1.0\bin do PATH
  • Edycja fstab Zgodnie z http://www.mingw.org/wiki/Getting_Started » After Installing You Should … należy znaleźć plik <MSYS>/etc/fstab.sample> i skopiować jego zawartość do <MSYS>/etc/fstab> (ewentualnie edytując ścieżkę).

Instalacja Eclipse

Eclipse

Najnowsza wersja (październik 2013) to Kepler. Można ją pobrać ze strony http://www.eclipse.org/downloads/

Przydatna będzie:

  • Eclipse IDE for Java Developers lub
  • Eclipse IDE for C/C++ Developers wersja ograniczona do C/C++

Proponuję zainstalować Eclipse IDE for Java Developers, ponieważ przy okazji pobrane zostaną rozszerzenia typu git lub maven.

Instalacja Eclipse polega na pobraniu pliku ZIP i rozpakowaniu w wybranym miejscu. Jeżeli nie zależy nam na oszczędzaniu miejsca, równolegle możemy mieć kilka instalacji na dysku: jedną dla C/C++, drugą dla Java. Wtedy możemy pominąć następny krok.

CDT

Pakiet można pobrać ze strony http://www.eclipse.org/cdt/. Pobieranie i instalację przeprowadzamy następująco:

  • Wybieramy w Eclipse Help→Install new software.
  • Otwieramy stronę http://www.eclipse.org/cdt/downloads.php i szukamy swojej wersji Eclipse. Najnowsza (4.4) to Kepler, wcześniejsza (4.3) to Juno, jeszcze wcześniejsza (3.8) Indigo, etc.
  • Kopiujemy adres linku p2 software repository, np: http://download.eclipse.org/tools/cdt/releases/kepler, wklejamy w oknie w polu Work with: i naciskamy Enter…
  • Wybieramy pakiety z drzewka: C/C++ Development Tools oraz opcje dodatkowe, w zasadzie wszystko, co ma GNU, toolchain, debugger w nazwie.

Jeśli ten krok jest zbyt skomplikowany, można zainstalować dwie równoległe instancje Eclipse: jedną dla Java, drugą dla C/C++.

Testujemy instalację

  • Wybieramy File→New→C++ Project, wpisujemy nazwę Hello oraz Tool chain: MinGW. Na obrazku jest kilka łańcuchów narzędzi do wyboru, bo takie były wcześniej zainstalowane. Jeśli nic się tu nie pojawi, należy sprawdzić instalację MinGW.

  • Zostanie wygenerowany kod

  • Wybieramy Project→Build project
  • Następnie Debug (F11) lub symbol żuczka. Eclipse poinformuje o zmianie perspektywy (układu okien). Zaakceptujemy zmianę… Program wykona się.

Release vs. Debug

Od dobrych 15 lat popularne IDE wspierają dwie konfiguracje C/C++:

  • Debug - wybierane są opcje kompilatora, które osadzają informacje dla debuggera w pliku wykonywalnym
  • Release - brak informacji dla uruchamiania programu, przeprowadzana jest optymalizacja kodu

Zazwyczaj dla każdej z nich można ustawiać osobne opcje kompilacji i wykonania.

Aktualną konfigurację ustawia się w Project→Build configurations→Set Active→{Debug|Release}. Po skompilowaniu w trybie Debug mozemy uruchomić program: Run (Ctrl+F11) lub śledzić wykonanie Debug (F11). Dla Release możliwe jest jedynie uruchomienie.

Po utworzeniu projektu, aktywną konfiguracją jest Debug.

swo/instalacja_eclipse_cdt.txt · ostatnio zmienione: 2013/10/03 przez pszwed

Narzędzia strony